summaryrefslogtreecommitdiff
path: root/lib/Target/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'lib/Target/CMakeLists.txt')
-rw-r--r--lib/Target/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/lib/Target/CMakeLists.txt b/lib/Target/CMakeLists.txt
index d91940aea44..6620882f227 100644
--- a/lib/Target/CMakeLists.txt
+++ b/lib/Target/CMakeLists.txt
@@ -14,6 +14,12 @@ add_llvm_library(LLVMTarget
TargetSubtargetInfo.cpp
)
+add_llvm_library_dependencies(LLVMTarget
+ LLVMCore
+ LLVMMC
+ LLVMSupport
+ )
+
set(LLVM_ENUM_ASM_PRINTERS "")
set(LLVM_ENUM_ASM_PARSERS "")
set(LLVM_ENUM_DISASSEMBLERS "")