summaryrefslogtreecommitdiff
path: root/unittests/CMakeLists.txt
diff options
context:
space:
mode:
authorChandler Carruth <chandlerc@gmail.com>2011-12-16 08:58:59 +0000
committerChandler Carruth <chandlerc@gmail.com>2011-12-16 08:58:59 +0000
commitd916ce3c8e1c88352703db12b47862b1794c7dad (patch)
tree6e47e776607739e93b30c452d06cc2afda2d22ac /unittests/CMakeLists.txt
parent9646acfccfae3e5dd4fc18bbb14b0a5c9cc9563e (diff)
Add a generic collection of class templates to ADT for building
variadic-like functions in C++98. See the comments in the header file for a more detailed description of how these work. We plan to use these extensively in the AST matching library. This code and idea were originally authored by Zhanyong Wan. I've condensed it using macros to reduce repeatition and adjusted it to fit better with LLVM's ADT. Thanks to both David Blaikie and Doug Gregor for the review! git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@146729 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'unittests/CMakeLists.txt')
-rw-r--r--unittests/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/unittests/CMakeLists.txt b/unittests/CMakeLists.txt
index 15423dce460..0fabf710661 100644
--- a/unittests/CMakeLists.txt
+++ b/unittests/CMakeLists.txt
@@ -73,6 +73,7 @@ add_llvm_unittest(ADT
ADT/StringRefTest.cpp
ADT/TripleTest.cpp
ADT/TwineTest.cpp
+ ADT/VariadicFunctionTest.cpp
)
add_llvm_unittest(Analysis