summaryrefslogtreecommitdiff
path: root/unittests/CMakeLists.txt
diff options
context:
space:
mode:
authorMichael J. Spencer <bigcheesegs@gmail.com>2010-10-19 18:04:19 +0000
committerMichael J. Spencer <bigcheesegs@gmail.com>2010-10-19 18:04:19 +0000
commit8a806aed4b3a0f1ec708d6bd6bf50dacc977d455 (patch)
tree970b1fb5b4af067e56cec946d71dfeb33e49b83b /unittests/CMakeLists.txt
parent01734b1e1bc482e67f4d1518b2b6c97e2c0a589c (diff)
unittests: Use the correct defines and global variables when building on CMake.
git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@116834 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'unittests/CMakeLists.txt')
-rw-r--r--unittests/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/unittests/CMakeLists.txt b/unittests/CMakeLists.txt
index 8a5a367794b..d37b8906b48 100644
--- a/unittests/CMakeLists.txt
+++ b/unittests/CMakeLists.txt
@@ -13,6 +13,8 @@ function(add_llvm_unittest test_name)
endfunction()
include_directories(${LLVM_MAIN_SRC_DIR}/utils/unittest/googletest/include)
+set(LLVM_REQUIRES_RTTI 1)
+add_definitions(-DGTEST_HAS_RTTI=0)
set(LLVM_LINK_COMPONENTS
jit