summaryrefslogtreecommitdiff
path: root/tools/llvm-readobj/CMakeLists.txt
diff options
context:
space:
mode:
authorEric Christopher <echristo@gmail.com>2013-04-03 18:31:38 +0000
committerEric Christopher <echristo@gmail.com>2013-04-03 18:31:38 +0000
commit76e70f340c09ba759ad96d8dfe416b64f24bc287 (patch)
treeac6cbe6235f9bf391026db87c52a0d617d35c9ba /tools/llvm-readobj/CMakeLists.txt
parent99ff2ba240979249b61514c1536bbe23be84ecc7 (diff)
Implements low-level object file format specific output for COFF and
ELF with support for: - File headers - Section headers + data - Relocations - Symbols - Unwind data (only COFF/Win64) The output format follows a few rules: - Values are almost always output one per line (as elf-dump/coff-dump already do). - Many values are translated to something readable (like enum names), with the raw value in parentheses. - Hex numbers are output in uppercase, prefixed with "0x". - Flags are sorted alphabetically. - Lists and groups are always delimited. Example output: ---------- snip ---------- Sections [ Section { Index: 1 Name: .text (5) Type: SHT_PROGBITS (0x1) Flags [ (0x6) SHF_ALLOC (0x2) SHF_EXECINSTR (0x4) ] Address: 0x0 Offset: 0x40 Size: 33 Link: 0 Info: 0 AddressAlignment: 16 EntrySize: 0 Relocations [ 0x6 R_386_32 .rodata.str1.1 0x0 0xB R_386_PC32 puts 0x0 0x12 R_386_32 .rodata.str1.1 0x0 0x17 R_386_PC32 puts 0x0 ] SectionData ( 0000: 83EC04C7 04240000 0000E8FC FFFFFFC7 |.....$..........| 0010: 04240600 0000E8FC FFFFFF31 C083C404 |.$.........1....| 0020: C3 |.| ) } ] ---------- snip ---------- Relocations and symbols can be output standalone or together with the section header as displayed in the example. This feature set supports all tests in test/MC/COFF and test/MC/ELF (and I suspect all additional tests using elf-dump), making elf-dump and coff-dump deprecated. Patch by Nico Rieck! git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@178679 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'tools/llvm-readobj/CMakeLists.txt')
-rw-r--r--tools/llvm-readobj/CMakeLists.txt13
1 files changed, 11 insertions, 2 deletions
diff --git a/tools/llvm-readobj/CMakeLists.txt b/tools/llvm-readobj/CMakeLists.txt
index 676c23d7ae6..3d20def8f51 100644
--- a/tools/llvm-readobj/CMakeLists.txt
+++ b/tools/llvm-readobj/CMakeLists.txt
@@ -1,6 +1,15 @@
-set(LLVM_LINK_COMPONENTS archive bitreader object)
+set(LLVM_LINK_COMPONENTS
+ ${LLVM_TARGETS_TO_BUILD}
+ archive
+ bitreader
+ object)
add_llvm_tool(llvm-readobj
- ELF.cpp
llvm-readobj.cpp
+ ObjDumper.cpp
+ COFFDumper.cpp
+ ELFDumper.cpp
+ MachODumper.cpp
+ Error.cpp
+ StreamWriter.cpp
)