summaryrefslogtreecommitdiff
path: root/tools/llvm-config/CMakeLists.txt
diff options
context:
space:
mode:
authorOscar Fuentes <ofv@wanadoo.es>2008-11-09 20:26:31 +0000
committerOscar Fuentes <ofv@wanadoo.es>2008-11-09 20:26:31 +0000
commit63b27a61f8d6fa1d8c5728f7da4d3bfb0f684a7d (patch)
tree7cd47d39ebf3314e18af14828f918360198d87fb /tools/llvm-config/CMakeLists.txt
parent3ab40ca3d507ec9d212a3ba498e0d6837634a5ad (diff)
CMake: Corrected detection of `nm'.
git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@58941 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'tools/llvm-config/CMakeLists.txt')
-rw-r--r--tools/llvm-config/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/tools/llvm-config/CMakeLists.txt b/tools/llvm-config/CMakeLists.txt
index 9f1f2f2d311..b4c97ec6b5e 100644
--- a/tools/llvm-config/CMakeLists.txt
+++ b/tools/llvm-config/CMakeLists.txt
@@ -67,8 +67,10 @@ if( CMAKE_CROSSCOMPILING )
set(CMAKE_FIND_ROOT_PATH_MODE_PROGRAM ONLY)
endif()
+find_program(NM_PATH nm PATH_SUFFIXES /bin)
+
if( NOT NM_PATH )
- message(FATAL_ERROR "`nm' was not found")
+ message(FATAL_ERROR "`nm' not found")
endif()
add_custom_command(OUTPUT ${LIBDEPS_TMP}