summaryrefslogtreecommitdiff
path: root/tools/llvm-config/CMakeLists.txt
diff options
context:
space:
mode:
authorChandler Carruth <chandlerc@gmail.com>2011-11-02 17:22:57 +0000
committerChandler Carruth <chandlerc@gmail.com>2011-11-02 17:22:57 +0000
commit05a484b909935b26533ffe81f6cb426085ff78a8 (patch)
treed37131d648df259e41854a8baa3123b2e01d738c /tools/llvm-config/CMakeLists.txt
parent87633026d65acf8253e953bdcfd20bc351631f61 (diff)
Add back the top-level target for 'llvm-config' and the dependency edge
to force it to build after all library targets so it has complete dependency information. This should fix broken 'make install' with CMake. This is a partial revert of r143540, but it doesn't revert the most important part of that change: removing the dependency edge from LLVM tools to the llvm-config script. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@143548 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'tools/llvm-config/CMakeLists.txt')
-rw-r--r--tools/llvm-config/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/tools/llvm-config/CMakeLists.txt b/tools/llvm-config/CMakeLists.txt
index 966557cc5cf..53f00846b79 100644
--- a/tools/llvm-config/CMakeLists.txt
+++ b/tools/llvm-config/CMakeLists.txt
@@ -125,6 +125,13 @@ add_custom_command(OUTPUT ${LLVM_CONFIG}
COMMENT "Building llvm-config script."
)
+add_custom_target(llvm-config.target ALL
+ DEPENDS ${LLVM_CONFIG})
+
+# Ensure we build llvm-config after we build all of the libraries so that we
+# have their full dependencies.
+add_dependencies(llvm-config.target ${llvm_libs})
+
install(FILES ${LLVM_CONFIG}
PERMISSIONS OWNER_READ OWNER_WRITE OWNER_EXECUTE GROUP_READ GROUP_EXECUTE
WORLD_READ WORLD_EXECUTE