summaryrefslogtreecommitdiff
path: root/tools/CMakeLists.txt
diff options
context:
space:
mode:
authorDuncan Sands <baldrick@free.fr>2011-12-01 10:50:19 +0000
committerDuncan Sands <baldrick@free.fr>2011-12-01 10:50:19 +0000
commitf6ace1924344b6bbeafe82494138f9673c22bddc (patch)
tree556db7585a5afe5e322abde5514af86b7ea95a76 /tools/CMakeLists.txt
parent7d5a61e975260d01bb2079b5dcb9c93b76a4734d (diff)
Revert commit 145449 (ddunbar) since it is breaking the dragonegg buildbots.
Original commit message: llvm-config: Replace with C++ version (was llvm-config-2). - Reapply of r144300, with lots of fixes/migration easement in between. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@145582 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'tools/CMakeLists.txt')
-rw-r--r--tools/CMakeLists.txt11
1 files changed, 9 insertions, 2 deletions
diff --git a/tools/CMakeLists.txt b/tools/CMakeLists.txt
index ec0647124b6..edfd3b2b719 100644
--- a/tools/CMakeLists.txt
+++ b/tools/CMakeLists.txt
@@ -11,9 +11,16 @@ if( EXISTS ${CMAKE_CURRENT_SOURCE_DIR}/polly/CMakeLists.txt )
endif( EXISTS ${CMAKE_CURRENT_SOURCE_DIR}/polly/CMakeLists.txt )
if( NOT WIN32 OR MSYS OR CYGWIN )
- # We currently require 'sed' to build llvm-config, so don't try to build it
- # on pure Win32.
+ # It is useful to build llvm-config before the other tools, so we
+ # have a fresh LibDeps.txt for regenerating the hard-coded library
+ # dependencies. llvm-config/CMakeLists.txt takes care of this but we
+ # must keep llvm-config as the first entry on the list of tools to
+ # be built.
add_subdirectory(llvm-config)
+
+ # We currently require 'sed' to build llvm-config-2, so don't try to build it
+ # on pure Win32.
+ add_subdirectory(llvm-config-2)
endif()
add_subdirectory(opt)