summaryrefslogtreecommitdiff
path: root/tools/CMakeLists.txt
diff options
context:
space:
mode:
authorHans Wennborg <hans@hanshq.net>2013-08-23 17:59:13 +0000
committerHans Wennborg <hans@hanshq.net>2013-08-23 17:59:13 +0000
commit3eb7322ca15e61f002be95341f74d1df8c1146bb (patch)
tree6cc67be7fc01b7b6efa37c151429eea2680ce5b6 /tools/CMakeLists.txt
parent12d3dc73dc44acd8b11cca783b826ccbd66f44da (diff)
CMake: build llvm-config on Windows.
It was previously not being built on Windows because the cmake file relied on a sed script to generate a .in file that llvm-config needs. By using cmake's configure_file function, we can get rid off the sed hack, and also have this work on Windows. Differential Revision: http://llvm-reviews.chandlerc.com/D1481 git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@189125 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'tools/CMakeLists.txt')
-rw-r--r--tools/CMakeLists.txt8
1 files changed, 1 insertions, 7 deletions
diff --git a/tools/CMakeLists.txt b/tools/CMakeLists.txt
index 66271a9f0ac..8a635a5b33a 100644
--- a/tools/CMakeLists.txt
+++ b/tools/CMakeLists.txt
@@ -2,13 +2,7 @@
# three small executables. This is done to minimize memory load in parallel
# builds. Please retain this ordering.
-if( NOT WIN32 OR MSYS OR CYGWIN )
- # We currently require 'sed' to build llvm-config, so don't try to build it
- # on pure Win32.
- add_llvm_tool_subdirectory(llvm-config)
-else()
- ignore_llvm_tool_subdirectory(llvm-config)
-endif()
+add_llvm_tool_subdirectory(llvm-config)
add_llvm_tool_subdirectory(opt)
add_llvm_tool_subdirectory(llvm-as)