summaryrefslogtreecommitdiff
path: root/lib/CodeGen/CMakeLists.txt
diff options
context:
space:
mode:
authorCameron Zwarich <zwarich@apple.com>2010-12-05 19:51:05 +0000
committerCameron Zwarich <zwarich@apple.com>2010-12-05 19:51:05 +0000
commita474685d069a900ab931ee1540c9a79fdd6607a9 (patch)
tree26af467723205dd3e209108c53bd7848a83638fb /lib/CodeGen/CMakeLists.txt
parentea388f217b8368db13f598e4c547bab5582eb82a (diff)
Move the FindCopyInsertPoint method of PHIElimination to a new standalone
function so that it can be shared with StrongPHIElimination. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@120951 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/CodeGen/CMakeLists.txt')
-rw-r--r--lib/CodeGen/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/CodeGen/CMakeLists.txt b/lib/CodeGen/CMakeLists.txt
index ed7ec6ea50d..2f6d60ff5e8 100644
--- a/lib/CodeGen/CMakeLists.txt
+++ b/lib/CodeGen/CMakeLists.txt
@@ -50,6 +50,7 @@ add_llvm_library(LLVMCodeGen
OcamlGC.cpp
OptimizePHIs.cpp
PHIElimination.cpp
+ PHIEliminationUtils.cpp
Passes.cpp
PeepholeOptimizer.cpp
PostRAHazardRecognizer.cpp