summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMichael J. Spencer <bigcheesegs@gmail.com>2010-10-11 19:55:38 +0000
committerMichael J. Spencer <bigcheesegs@gmail.com>2010-10-11 19:55:38 +0000
commitbbb9ea7b70971df53eedfb42fc9cb606f815eaaa (patch)
treee898eff89f6d5f9e063c953545446a2aab89d788 /CMakeLists.txt
parentc4bd6fbf4bdf4dd3d9f69ec7bed1ea7ebfaab621 (diff)
Add KillTheDoctor.
git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@116216 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 414c32e0056..c3f0b1b11f7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -389,6 +389,11 @@ if( LLVM_INCLUDE_TESTS )
add_subdirectory(test)
add_subdirectory(utils/unittest)
add_subdirectory(unittests)
+ if (WIN32)
+ # This utility is used to prevent chrashing tests from calling Dr. Watson on
+ # Windows.
+ add_subdirectory(utils/KillTheDoctor)
+ endif()
endif()
add_subdirectory(cmake/modules)