summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorManuel Klimek <klimek@google.com>2012-05-09 15:10:54 +0000
committerManuel Klimek <klimek@google.com>2012-05-09 15:10:54 +0000
commit80fa4723b9b7cb9d78d71648095e4e2804681402 (patch)
tree54316e99ff4387ec60987e2d5d6805f7f9d3b495 /CMakeLists.txt
parent7305295538f0fd53cd3ed15eb8983f286e523a7a (diff)
Make it possible to switch off solution folders. VS Express does not support
them, and requires the user to click away one error message per folder on project load. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@156472 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9fcdd247ec1..7f4dea95efd 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -15,7 +15,10 @@ set(LLVM_VERSION_MINOR 2)
set(PACKAGE_VERSION "${LLVM_VERSION_MAJOR}.${LLVM_VERSION_MINOR}svn")
-set_property(GLOBAL PROPERTY USE_FOLDERS ON)
+option(LLVM_USE_FOLDERS "Enable solution folders in Visual Studio. Disable for Express versions." ON)
+if ( LLVM_USE_FOLDERS )
+ set_property(GLOBAL PROPERTY USE_FOLDERS ON)
+endif()
include(VersionFromVCS)