summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChandler Carruth <chandlerc@gmail.com>2014-02-28 21:30:03 +0000
committerChandler Carruth <chandlerc@gmail.com>2014-02-28 21:30:03 +0000
commit7166b2820d4ede88e165c9a8010103cc6e28617b (patch)
tree401af30f54a870729c48b2d910607ec46e68d9d0 /CMakeLists.txt
parentffbfa9f25903112a1b534bcdd4abfe4bf57de9de (diff)
[C++11] Switch CMake to use C++11 by default! Next up, autoconf/make!
Now, please don't get too excited. I've just toggled the default to suss out the last remaining bot problems. This does *not* mean we can all go write lots of C++11 code yet. I at least want to let the dust settle from the bots first. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@202542 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ab93503f282..24c799915f9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -203,7 +203,7 @@ else( MSVC )
option(LLVM_ENABLE_WARNINGS "Enable compiler warnings." ON)
endif()
-option(LLVM_ENABLE_CXX11 "Compile with C++11 enabled." OFF)
+option(LLVM_ENABLE_CXX11 "Compile with C++11 enabled." ON)
option(LLVM_ENABLE_LIBCXX "Use libc++ if available." OFF)
option(LLVM_ENABLE_PEDANTIC "Compile with pedantic enabled." ON)
option(LLVM_ENABLE_WERROR "Fail and stop if a warning is triggered." OFF)