summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorOscar Fuentes <ofv@wanadoo.es>2009-08-18 15:29:35 +0000
committerOscar Fuentes <ofv@wanadoo.es>2009-08-18 15:29:35 +0000
commit1e02bf092a9fd770add1e416121411e30afd86b3 (patch)
treeb7277ed5e746a9eef74a79d20d5b75d5e96c4066 /CMakeLists.txt
parentda65822cfc938594f8fb7840947c1eb77e057a48 (diff)
CMake: LLVM_ENABLE_PIC now defaults to ON, as in `configure'. This is
required on some platforms for building shared libraries that link to the LLVM libraries. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@79339 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ae858f57945..a95ca51d18a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -159,7 +159,7 @@ endif(WIN32)
include(config-ix)
-option(LLVM_ENABLE_PIC "Build Position-Independent Code" OFF)
+option(LLVM_ENABLE_PIC "Build Position-Independent Code" ON)
set(ENABLE_PIC 0)
if( LLVM_ENABLE_PIC )