summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChad Versace <chad.versace@linux.intel.com>2013-08-19 22:24:42 -0700
committerChad Versace <chad.versace@linux.intel.com>2013-08-19 23:44:55 -0700
commit8cd7a22db9691668e2c44a1367f891a2af6caf33 (patch)
treee1bc7f1a223ff57431591a0d41ae1d23440be976 /CMakeLists.txt
parent73487244dcc40106e421c8ed917bc5c2ef080aef (diff)
cmake: Refactor configuration summary
Move the large block that prints the configuration summary into a new module WafflePrintConfigurationSummary. This change belongs to a series that cleans up the toplevel CMakeLists by decompositing it into modules. Signed-off-by: Chad Versace <chad.versace@linux.intel.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt66
1 files changed, 1 insertions, 65 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 625ea8a..53cc5c0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -256,69 +256,5 @@ install(FILES ${CMAKE_BINARY_DIR}/${waffle_libname}.pc
DESTINATION ${CMAKE_INSTALL_FULL_LIBDIR}/pkgconfig)
# ------------------------------------------------------------------------------
-# Print summary
-# ------------------------------------------------------------------------------
-
-# CMake is annoyingly silent compared to autoconf. The user wants to know what
-# was configured how.
-message("-----------------------------------------------")
-message("")
-message("Waffle configuration summary")
-message("")
-message("Supported platforms: ")
-if(waffle_has_glx)
- message(" glx")
-endif()
-if(waffle_has_wayland)
- message(" wayland")
-endif()
-if(waffle_has_x11_egl)
- message(" x11_egl")
-endif()
-if(waffle_has_gbm)
- message(" gbm")
-endif()
-message("")
-message("Dependencies:")
-if(waffle_has_egl)
- message(" egl_INCLUDE_DIRS: ${egl_INCLUDE_DIRS}")
- message(" egl_LDFLAGS: ${egl_LDFLAGS}")
-endif()
-if(waffle_has_glx)
- message(" gl_INCLUDE_DIRS: ${gl_INCLUDE_DIRS}")
- message(" gl_LDFLAGS: ${gl_LDFLAGS}")
-endif()
-if(waffle_has_wayland)
- message(" wayland-client_INCLUDE_DIRS: ${wayland-client_INCLUDE_DIRS}")
- message(" wayland-client_LDFLAGS: ${wayland-client_LDFLAGS}")
- message(" wayland-egl_INCLUDE_DIRS: ${wayland-egl_INCLUDE_DIRS}")
- message(" wayland-egl_LDFLAGS: ${wayland-egl_LDFLAGS}")
-endif()
-if(waffle_has_x11)
- message(" x11-xcb_INCLUDE_DIRS: ${x11-xcb_INCLUDE_DIRS}")
- message(" x11-xcb_LDFLAGS: ${x11-xcb_LDFLAGS}")
-endif()
-if(waffle_has_gbm)
- message(" gbm_INCLUDE_DIRS: ${gbm_INCLUDE_DIRS}")
- message(" gbm_LDFLAGS: ${gbm_LDFLAGS}")
-endif()
-message("")
-message("Build type:")
-message(" ${CMAKE_BUILD_TYPE}")
-message("")
-message("Tools:")
-message(" CMAKE_C_COMPILER: ${CMAKE_C_COMPILER}")
-message(" CMAKE_C_FLAGS: ${CMAKE_C_FLAGS}")
-message(" CMAKE_C_FLAGS_DEBUG: ${CMAKE_C_FLAGS_DEBUG}")
-message(" CMAKE_C_FLAGS_RELEASE: ${CMAKE_C_FLAGS_RELEASE}")
-if(waffle_build_manpages OR waffle_build_htmldocs)
-message(" xsltproc: ${waffle_xsltproc}")
-endif()
-message("")
-message("Install paths:")
-message(" CMAKE_INSTALL_PREFIX: ${CMAKE_INSTALL_PREFIX}")
-message(" CMAKE_INSTALL_INCLUDEDIR: ${CMAKE_INSTALL_INCLUDEDIR}")
-message(" CMAKE_INSTALL_LIBDIR: ${CMAKE_INSTALL_LIBDIR}")
-message(" CMAKE_INSTALL_DOCDIR: ${CMAKE_INSTALL_DOCDIR}")
-message("-----------------------------------------------")
+include(WafflePrintConfigurationSummary)