summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChad Versace <chad.versace@linux.intel.com>2013-12-01 21:39:04 -0800
committerChad Versace <chad.versace@linux.intel.com>2013-12-01 22:02:25 -0800
commit8123e54dd6425d828ad8a281cebebcdfd2ad896e (patch)
treea78d8bdd962e4baa1d5423ae88a349225e9a683b /CMakeLists.txt
parent4b45d3f7b036a7dd6dcb71ad139bce9b928933ed (diff)
parent2361075e27db8e0536eecb18d7168cfe02181c50 (diff)
Merge branch 'cmocka'
This merge makes progress towards killing off libwaffle_test and replacing it with cmocka. - Add subtree 'third_party/cmocka' from tag cmocka-0.3.2. - Convert all unit test executables to use cmocka. They no longer use libwaffle_test. - The only remaining user of libwaffle_test is gl_basic_test, which I will also move to cmocka eventually.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a6c804a..ba6af40 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -38,6 +38,10 @@ include(WaffleDefineCompilerFlags)
include(WaffleFindDependencies)
include(GNUInstallDirs)
+if(waffle_build_tests)
+ include(WaffleCMocka)
+endif()
+
find_package(PkgConfig)
# ------------------------------------------------------------------------------