summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChad Versace <chad.versace@linux.intel.com>2014-06-23 09:22:49 -0700
committerChad Versace <chad.versace@linux.intel.com>2014-09-06 12:46:01 -0700
commit461f0ad0b76b444d9837d7ed5a88046ab46f2f37 (patch)
treeef5ac4c20695712e5d4d055d2eea15c932467f6f /CMakeLists.txt
parentfdf11fa8f23db2b1a62e7946a87f729d0e9ce37a (diff)
cmake: Move install rule for README, LICENSE
The rule lived in a strange place. The sources for the installation rule lived in the directory *above* the rule. Move the rule from "$TOP/doc/CMakeLists.txt" to "$TOP/CMakeLists.txt". Signed-off-by: Chad Versace <chad.versace@linux.intel.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8e62e40..4f159da 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -112,5 +112,17 @@ install(
)
# ------------------------------------------------------------------------------
+# Install core documentation
+# ------------------------------------------------------------------------------
+
+install(
+ FILES
+ "README.txt"
+ "LICENSE.txt"
+ DESTINATION "${CMAKE_INSTALL_DOCDIR}"
+ COMPONENT coredocs
+ )
+
+# ------------------------------------------------------------------------------
include(WafflePrintConfigurationSummary)