summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChad Versace <chad.versace@linux.intel.com>2014-11-05 15:16:43 -0800
committerChad Versace <chad.versace@linux.intel.com>2014-11-05 15:19:28 -0800
commit373361aeedee21c2c2caf78005facccb68990e2d (patch)
treedd0c241513c185568738e250038715d11f34de72 /CMakeLists.txt
parentafdfb88fab2f87ad96ab75d521c82bb34970927a (diff)
parent3413e4f32ac63679d685b686eee48442459ec835 (diff)
Merge branch 'evelikov/for-upstream-3.2-pull' into master
* evelikov/for-upstream-3.2-pull: third_party/getopt: include BSD licensed getopt implementation core: convert wcore_error_unittest to c11 threads core: Convert to c11 threads third_party/threads: use intptr_t for int<>void* typecasting third_party/threads: add missing brackets around _MTX_INITIALIZER_NP third_party/threads: correct assertion third_party/threads: import c11 threads emulation wrappers c99: use strerror_s over strerror_r under Windows c99: add snprintf and strcasecmp c99: define inline keyword and use it across waffle core c99: move restrict keyword to c99_compat.h header waffle_test: build as a static library wflinfo: silence signed/unsigned comparison warning core: return false on failure in waffle_window_resize linux: plug a memory leak Signed-off-by: Chad Versace <chad.versace@linux.intel.com> Conflicts: src/waffle/CMakeLists.txt Evelikov on master refactor how CMake linked libraries into libwaffle. Fix conflict by applying refactor to THREADS_LIBRARIES.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 474d203..ff1c222 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -93,6 +93,20 @@ include_directories(
src
)
+add_subdirectory(third_party/threads)
+include_directories(
+ third_party/threads
+ )
+set(THREADS_LIBRARIES threads_bundled)
+
+if(MSVC)
+ add_subdirectory(third_party/getopt)
+ include_directories(
+ third_party/getopt
+ )
+ set(GETOPT_LIBRARIES getopt_bundled)
+endif()
+
add_subdirectory(doc)
add_subdirectory(src)
add_subdirectory(include)