summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorEmil Velikov <emil.l.velikov@gmail.com>2014-07-04 04:15:02 +0100
committerEmil Velikov <emil.l.velikov@gmail.com>2014-07-22 19:58:03 +0100
commit3413e4f32ac63679d685b686eee48442459ec835 (patch)
tree9d7082d730dbe069af114eee18f023d708976ba6 /CMakeLists.txt
parentff4ac46c59c43281d06fadb5feaf30bceed9edbb (diff)
third_party/getopt: include BSD licensed getopt implementation
This module has been ripped out of the apitrace project https://github.com/apitrace/apitrace Used by utils/wflinfo and examples/gl_basic. Signed-off-by: Emil Velikov <emil.l.velikov@gmail.com> Reviewed-by: Brian Paul <brianp@vmware.com> Reviewed-by: Jose Fonseca <jfonseca@vmware.com> Reviewed-by: Chad Versace <chad.versace@linux.intel.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 325b7ee..1ce5a86 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -86,6 +86,14 @@ include_directories(
)
set(THREADS_LIBRARIES threads_bundled)
+if(MSVC)
+ add_subdirectory(third_party/getopt)
+ include_directories(
+ third_party/getopt
+ )
+ set(GETOPT_LIBRARIES getopt_bundled)
+endif()
+
add_subdirectory(doc)
add_subdirectory(src)
add_subdirectory(include)