summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorEmil Velikov <emil.l.velikov@gmail.com>2014-06-06 14:18:37 +0100
committerChad Versace <chad.versace@linux.intel.com>2014-06-10 21:31:25 -0700
commit1f8862746c6237f90c56c2de56d07d317f8f4915 (patch)
treee3720875ef6134f9aac6ded37b071a24743b4086 /CMakeLists.txt
parent68c1ba8f0f3fbbc60d6fc25b9f54b5f6ef73b6d0 (diff)
cmake: add autodetection for waffle_has_egl, glx...
Silence the pkg_check_modules and check set the default options depending on the packages found. Error out if the user has selected an option and it's requirements are not met. v2: - Do not silence pkg_check_modules. - Explicitly list the failing requirements. Signed-off-by: Emil Velikov <emil.l.velikov@gmail.com> Reviewed-by: Chad Versace <chad.versace@linux.intel.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b32b3d1..cf19929 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -30,12 +30,12 @@ cmake_minimum_required(VERSION 2.8)
list(APPEND CMAKE_MODULE_PATH "${CMAKE_SOURCE_DIR}/cmake/Modules")
include(WaffleDefineOS)
+include(WaffleFindDependencies)
include(Options.cmake)
include(WaffleDefineInternalOptions)
include(WaffleValidateOptions)
include(WaffleDefineVersion)
include(WaffleDefineCompilerFlags)
-include(WaffleFindDependencies)
include(GNUInstallDirs)
if(waffle_build_tests)