summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChad Versace <chad.versace@linux.intel.com>2013-11-24 17:00:17 -0800
committerChad Versace <chad.versace@linux.intel.com>2013-11-27 11:37:22 -0800
commit163cb32c5c2a7a793a32e694dd0f9e61ac305570 (patch)
tree4ba8e1ec5d5c9ae5157f32caf84e483c04f60bf9 /CMakeLists.txt
parent96b047377a1aba7992051ddd7e5bb20732da067c (diff)
cmake: Move targets check, check-func to top dir
By moving 'check' to the top dir, each subdirectory can now add dependencies to 'check'. Ditto for 'check-func'. This change will allow us to build each unittest file as a separate executable, as well as maintain the CMake rules for the unittest in in the same directory as its sources. Signed-off-by: Chad Versace <chad.versace@linux.intel.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt19
1 files changed, 19 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 312c060..e71f098 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -41,6 +41,25 @@ include(GNUInstallDirs)
find_package(PkgConfig)
# ------------------------------------------------------------------------------
+# Targets: check, check-func
+# ------------------------------------------------------------------------------
+
+#
+# Target 'check' runs unit tests, but no functional tests.
+#
+add_custom_target(check)
+
+#
+# Target 'check-func' runs functional tests as well as unit tests.
+#
+# The unit tests are ran first (due to the depenency on 'check'). If any unit
+# test fails, then no functional tests run.
+#
+add_custom_target(check-func
+ DEPENDS check
+ )
+
+# ------------------------------------------------------------------------------
# Add subdirectories
# ------------------------------------------------------------------------------