summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorEmil Velikov <emil.l.velikov@gmail.com>2014-05-31 03:22:00 +0100
committerChad Versace <chad.versace@linux.intel.com>2014-06-05 20:52:20 -0700
commit001e84091b0a7bca03586e9aebd9103e9630bfa5 (patch)
tree52cbec8a8dbd4a67f509585a2b072116e3fc9a00 /CMakeLists.txt
parentd62f8178f9f29a5ab2942d03fdc251544eec7edb (diff)
cmake: reformat/update install targets
Cleanup the formatting and add component for each build target. The latter will allow us to use CPack to create a component based installer for Windows. Additionally install wflinfo to CMAKE_INSTALL_BINDIR rather than hardcoding it to 'bin'. v2: Tag html documentation as htmldocs COMPONENT. Suggested by Chad. Signed-off-by: Emil Velikov <emil.l.velikov@gmail.com> Reviewed-by: Chad Versace <chad.versace@linux.intel.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt14
1 files changed, 10 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d8d234d..b32b3d1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -92,11 +92,17 @@ endif()
configure_file(waffle.pc.in ${waffle_libname}.pc @ONLY)
-install(FILES ${CMAKE_BINARY_DIR}/${waffle_libname}.pc
- DESTINATION ${CMAKE_INSTALL_LIBDIR}/pkgconfig)
+install(
+ FILES ${CMAKE_BINARY_DIR}/${waffle_libname}.pc
+ DESTINATION ${CMAKE_INSTALL_LIBDIR}/pkgconfig
+ COMPONENT pkgconfig
+ )
-install(FILES cmake/Modules/FindWaffle.cmake
- DESTINATION "${CMAKE_INSTALL_DATAROOTDIR}/cmake/Modules")
+install(
+ FILES cmake/Modules/FindWaffle.cmake
+ DESTINATION "${CMAKE_INSTALL_DATAROOTDIR}/cmake/Modules"
+ COMPONENT cmakefind
+ )
# ------------------------------------------------------------------------------