summaryrefslogtreecommitdiff
path: root/telepathy-glib/Makefile.am
diff options
context:
space:
mode:
authorSimon McVittie <simon.mcvittie@collabora.co.uk>2014-03-31 15:38:14 +0100
committerSimon McVittie <simon.mcvittie@collabora.co.uk>2014-04-03 15:47:14 +0100
commit6f3b018c14c11533f4e33be8669abfb8d6ad49ca (patch)
treefb4fbfeec9d498768dead7cd84e0ad2948747a96 /telepathy-glib/Makefile.am
parentd7051489e3a50e180d756c255de103aff29878f3 (diff)
Split gnio-util.h into the Telepathy D-Bus API part, and the GIO part
The Telepathy D-Bus API part (the exact details of how we encode addresses) should go in the -dbus library; the GIO part should go in the main library. Use GIOError instead of TpError in the -dbus part, so TpError won't need to stay in the core library. Bug: https://bugs.freedesktop.org/show_bug.cgi?id=76855 Reviewed-by: Xavier Claessens
Diffstat (limited to 'telepathy-glib/Makefile.am')
-rw-r--r--telepathy-glib/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/telepathy-glib/Makefile.am b/telepathy-glib/Makefile.am
index 1465c670e..18268e201 100644
--- a/telepathy-glib/Makefile.am
+++ b/telepathy-glib/Makefile.am
@@ -99,7 +99,7 @@ tpginclude_HEADERS = \
errors.h \
exportable-channel.h \
file-transfer-channel.h \
- gnio-util.h \
+ gnio-unix.h \
group-mixin.h \
handle.h \
handle-channel-context.h \
@@ -140,6 +140,7 @@ tpgdbusinclude_HEADERS = \
cli-channel.h \
cli-connection.h \
cli-misc.h \
+ gnio-util.h \
gtypes.h \
interfaces.h \
sliced-gvalue.h \
@@ -206,6 +207,7 @@ libtelepathy_glib_dbus_internal_la_SOURCES = \
cli-channel.c \
cli-connection.c \
cli-misc.c \
+ gnio-util.c \
gtypes.c \
interfaces.c \
sliced-gvalue.c \
@@ -301,7 +303,7 @@ libtelepathy_glib_main_internal_la_SOURCES = \
debug-internal.h \
exportable-channel.c \
file-transfer-channel.c \
- gnio-util.c \
+ gnio-unix.c \
group-mixin.c \
handle.c \
handle-channel-context-internal.h \