summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorRonald <rbultje@ronald.bitfreak.net>2005-10-10 15:53:59 +0000
committerAndy Wingo <wingo@pobox.com>2005-10-10 15:53:59 +0000
commitac8289c7a952613f234af354088528e3531a9bf9 (patch)
treef9f97adde1425f6e130c09815142e291a09d3162 /tests/Makefile.am
parenta1702b7646c84f53892a7311458a6f306fa80775 (diff)
Merged in popt removal + GOption addition patch from Ronald, bug #169772.
Original commit message from CVS: 2005-10-10 Andy Wingo <wingo@pobox.com> Merged in popt removal + GOption addition patch from Ronald, bug #169772. * docs/gst/gstreamer-sections.txt: Add STATE_(UN)LOCK_FULL, move GstElement macros around, remove popt-related symbols, add goption stuff. * configure.ac: Remove popt checks, require GLib 2.6 for GOption. * docs/gst/Makefile.am: * docs/libs/Makefile.am: No POPT_CFLAGS. * examples/manual/Makefile.am: * docs/manual/basics-init.xml: Doc updates with an example. * gst/gst.c: (gst_init_get_option_group), (gst_init_check), (gst_init), (parse_one_option), (parse_goption_arg): * gst/gst.h: Removed gst_init_with_popt_table and friends. Took a bit of hand merging and debugging to get the GOption stuff working tho. * tests/Makefile.am: * tools/Makefile.am: * tools/gst-inspect.c: (main): * tools/gst-launch.c: (main): * tools/gst-run.c: (main): * tools/gst-xmlinspect.c: (main): Thanks Ronald!
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index a6cd4e4be..e8107d16c 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -8,7 +8,7 @@ LAT = lat
endif
-noinst_PROGRAMS = $(LAT) mass_elements complexity
+noinst_PROGRAMS = $(LAT) mass_elements complexity init
AM_CFLAGS = $(GST_OBJ_CFLAGS)
LIBS = $(GST_OBJ_LIBS) \