summaryrefslogtreecommitdiff
path: root/src/mesa/main/extensions.c
diff options
context:
space:
mode:
authorFrancisco Jerez <currojerez@riseup.net>2015-08-19 14:42:50 +0300
committerFrancisco Jerez <currojerez@riseup.net>2015-08-20 12:29:00 +0300
commitf5070c801c4885521df17a65c297f24ae628d414 (patch)
tree874b06e85e94c822dbc59ec132a675326f51689f /src/mesa/main/extensions.c
parent6379f5cb2ab7c5ae3f3769204f95088e35c53217 (diff)
mesa: Add ES31 API tag for the extension table.
I'll mark the OES_shader_image_atomic extension entry with this tag to make sure that we don't expose it on earlier GLES API versions accidentally, because according to the extension: "OpenGL ES 3.1 and GLSL ES 3.10 are required." Reviewed-by: Tapani Pälli <tapani.palli@intel.com>
Diffstat (limited to 'src/mesa/main/extensions.c')
-rw-r--r--src/mesa/main/extensions.c7
1 files changed, 7 insertions, 0 deletions
diff --git a/src/mesa/main/extensions.c b/src/mesa/main/extensions.c
index d934d19c3e..017de2d161 100644
--- a/src/mesa/main/extensions.c
+++ b/src/mesa/main/extensions.c
@@ -50,6 +50,7 @@ enum {
ES1 = 1 << API_OPENGLES,
ES2 = 1 << API_OPENGLES2,
ES3 = 1 << (API_OPENGL_LAST + 1),
+ ES31 = 1 << (API_OPENGL_LAST + 2),
};
/**
@@ -773,6 +774,8 @@ _mesa_make_extension_string(struct gl_context *ctx)
unsigned api_set = (1 << ctx->API);
if (_mesa_is_gles3(ctx))
api_set |= ES3;
+ if (_mesa_is_gles31(ctx))
+ api_set |= ES31;
/* Check if the MESA_EXTENSION_MAX_YEAR env var is set */
{
@@ -854,6 +857,8 @@ _mesa_get_extension_count(struct gl_context *ctx)
unsigned api_set = (1 << ctx->API);
if (_mesa_is_gles3(ctx))
api_set |= ES3;
+ if (_mesa_is_gles31(ctx))
+ api_set |= ES31;
/* only count once */
if (ctx->Extensions.Count != 0)
@@ -880,6 +885,8 @@ _mesa_get_enabled_extension(struct gl_context *ctx, GLuint index)
unsigned api_set = (1 << ctx->API);
if (_mesa_is_gles3(ctx))
api_set |= ES3;
+ if (_mesa_is_gles31(ctx))
+ api_set |= ES31;
base = (GLboolean*) &ctx->Extensions;
n = 0;