summaryrefslogtreecommitdiff
path: root/src/mesa/drivers/dri/common/drisw_util.c
diff options
context:
space:
mode:
authorDave Airlie <airlied@gmail.com>2012-12-09 20:28:56 +1000
committerDave Airlie <airlied@gmail.com>2012-12-09 20:28:56 +1000
commit157f5d043afe8cf7f47baa7b29cf6dfc756feb40 (patch)
treec3609729f86b97b40c0413acb43110a6ec112265 /src/mesa/drivers/dri/common/drisw_util.c
parentbd87441ac028068f422e2c96b39f93644a0f246f (diff)
drisw: fix up context and apis for software context
This ports over from the dri2 code to the drisw bits. It means 3.1 core contexts now work for softpipe. Signed-off-by: Dave Airlie <airlied@redhat.com>
Diffstat (limited to 'src/mesa/drivers/dri/common/drisw_util.c')
-rw-r--r--src/mesa/drivers/dri/common/drisw_util.c16
1 files changed, 16 insertions, 0 deletions
diff --git a/src/mesa/drivers/dri/common/drisw_util.c b/src/mesa/drivers/dri/common/drisw_util.c
index 8fdb05ec33..cd5a39a372 100644
--- a/src/mesa/drivers/dri/common/drisw_util.c
+++ b/src/mesa/drivers/dri/common/drisw_util.c
@@ -126,7 +126,10 @@ driCreateContextAttribs(__DRIscreen *screen, int api,
mesa_api = API_OPENGLES2;
break;
case __DRI_API_OPENGL_CORE:
+ mesa_api = API_OPENGL_CORE;
+ break;
default:
+ *error = __DRI_CTX_ERROR_BAD_API;
return NULL;
}
@@ -149,6 +152,19 @@ driCreateContextAttribs(__DRIscreen *screen, int api,
}
}
+ /* Mesa does not support the GL_ARB_compatibilty extension or the
+ * compatibility profile. This means that we treat a API_OPENGL_COMPAT 3.1 as
+ * API_OPENGL_CORE and reject API_OPENGL_COMPAT 3.2+.
+ */
+ if (mesa_api == API_OPENGL_COMPAT && major_version == 3 && minor_version == 1)
+ mesa_api = API_OPENGL_CORE;
+
+ if (mesa_api == API_OPENGL_COMPAT
+ && ((major_version > 3)
+ || (major_version == 3 && minor_version >= 2))) {
+ *error = __DRI_CTX_ERROR_BAD_API;
+ return NULL;
+ }
/* There are no forward-compatible contexts before OpenGL 3.0. The
* GLX_ARB_create_context spec says:
*