summaryrefslogtreecommitdiff
path: root/glamor/Makefile.am
diff options
context:
space:
mode:
authorZhigang Gong <zhigang.gong@linux.intel.com>2012-06-11 01:52:14 +0800
committerEric Anholt <eric@anholt.net>2013-12-18 11:23:51 -0800
commite96ea02010874a3a46f212f42134083bd29fefe3 (patch)
tree05c747c93c84789796ceced419e9195efaef3e82 /glamor/Makefile.am
parentace35e408cd7a79c5215bbd0f14b624d8d949e34 (diff)
largepixmap: Implement infrastructure for large pixmap.
Added infrastructure for largepixmap, this commit implemented: 1. Create/Destroy large pixmap. 2. Upload/Download large pixmap. 3. Implement basic repeat normal support. 3. tile/fill/copyarea large pixmap get supported. The most complicated part glamor_composite still not implemented. Signed-off-by: Zhigang Gong <zhigang.gong@linux.intel.com>
Diffstat (limited to 'glamor/Makefile.am')
-rw-r--r--glamor/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/glamor/Makefile.am b/glamor/Makefile.am
index 2e94ffd73..421846c62 100644
--- a/glamor/Makefile.am
+++ b/glamor/Makefile.am
@@ -42,6 +42,7 @@ libglamor_la_SOURCES = \
glamor_glyphblt.c\
glamor_polyops.c\
glamor_pixmap.c\
+ glamor_largepixmap.c\
glamor_picture.c\
glamor_window.c\
glamor_gl_dispatch.c\