summaryrefslogtreecommitdiff
path: root/glamor/Makefile.am
diff options
context:
space:
mode:
authorZhigang Gong <zhigang.gong@linux.intel.com>2012-01-18 19:21:36 +0800
committerEric Anholt <eric@anholt.net>2013-12-18 11:23:47 -0800
commit2ff41008494e6c5909c058f1f80b4f66617dada1 (patch)
tree540d0790d6524e147676687fabfd3980750efab8 /glamor/Makefile.am
parentca2ddd33a114fe83584b5fa9f73b7534abdb96fa (diff)
glamor_fbo: Introduce glamor fbo to manage all the fb/tex.
This is the first patch to implement a fbo/tex pool mechanism which is like the sna's BO cache list. We firstly need to decopule the fbo/tex from each pixmap. The new glamor_pixmap_fbo data structure is for that purpose. It's somehow independent to each pixmap and can be reused latter by other pixmaps once it's detached from the current pixmap. And this commit also slightly change the way to create a memory pixmap. We will not create a pixmap private data structure by default, instead we will crete that structure when a memory pixmap is attaching a fbo to it. Signed-off-by: Zhigang Gong <zhigang.gong@linux.intel.com>
Diffstat (limited to 'glamor/Makefile.am')
-rw-r--r--glamor/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/glamor/Makefile.am b/glamor/Makefile.am
index 5c5f7e5dc..d6105d002 100644
--- a/glamor/Makefile.am
+++ b/glamor/Makefile.am
@@ -44,6 +44,7 @@ libglamor_la_SOURCES = \
glamor_picture.c\
glamor_window.c\
glamor_gl_dispatch.c\
+ glamor_fbo.c\
glamor.h
sdk_HEADERS = glamor.h