summaryrefslogtreecommitdiff
path: root/glamor/Makefile.am
diff options
context:
space:
mode:
authorKeith Packard <keithp@keithp.com>2014-03-12 14:35:27 -0700
committerEric Anholt <eric@anholt.net>2014-03-26 12:58:40 -0700
commit1b5d7e78460ed686ba2da398dab341d4867fd4a0 (patch)
tree2b6294a9b68593ff28c5c9073b5533bdec37b577 /glamor/Makefile.am
parent72a4beff6d3aed767df9a30bca0c1d860715928f (diff)
glamor: Add glamor_program PolyPoint implementation
This accelerates poly point when possible by off-loading all geometry computation to the GPU. Improves x11perf -dot performance by 28109.5% +/- 1022.01% (n=3) Signed-off-by: Keith Packard <keithp@keithp.com> Signed-off-by: Eric Anholt <eric@anholt.net> Reviewed-by: Eric Anholt <eric@anholt.net>
Diffstat (limited to 'glamor/Makefile.am')
-rw-r--r--glamor/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/glamor/Makefile.am b/glamor/Makefile.am
index eff769eff..8555e4087 100644
--- a/glamor/Makefile.am
+++ b/glamor/Makefile.am
@@ -32,7 +32,7 @@ libglamor_la_SOURCES = \
glamor_getimage.c\
glamor_copyplane.c\
glamor_glyphblt.c\
- glamor_polyops.c\
+ glamor_points.c\
glamor_priv.h\
glamor_pixmap.c\
glamor_largepixmap.c\