summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJavier Jardón <jjardon@gnome.org>2011-02-08 22:33:12 +0000
committerChris Wilson <chris@chris-wilson.co.uk>2011-02-09 10:19:51 +0000
commit68b64f1b399e712a3b96b91568dc2b6d7e9b35d9 (patch)
tree1681e3419f0335de412345401ccbb1a3d2ef2d3e /configure.ac
parent293dd478d713eee5cedfa04749c97d1aa850df3c (diff)
build: Update autotools configuration
Replace deprecated macros and use the new libtool syntax Also use silent-rules to make the build option less verbose.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac28
1 files changed, 18 insertions, 10 deletions
diff --git a/configure.ac b/configure.ac
index 097d796..9fd8d35 100644
--- a/configure.ac
+++ b/configure.ac
@@ -20,26 +20,33 @@
#
# Process this file with autoconf to produce a configure script
-AC_PREREQ(2.57)
+AC_PREREQ([2.63])
AC_INIT([intel-gpu-tools],
- 1.0.2,
+ [1.0.2],
[https://bugs.freedesktop.org/enter_bug.cgi?product=xorg],
- intel-gpu-tools)
+ [intel-gpu-tools])
AC_CONFIG_SRCDIR([Makefile.am])
-AM_CONFIG_HEADER([config.h])
-AC_CONFIG_AUX_DIR(.)
+AC_CONFIG_HEADERS([config.h])
+AC_CONFIG_MACRO_DIR([m4])
+AC_CONFIG_AUX_DIR([build-aux])
-AM_INIT_AUTOMAKE([dist-bzip2])
+AM_INIT_AUTOMAKE([1.10 foreign dist-bzip2])
+AM_MAINTAINER_MODE([enable])
-AM_MAINTAINER_MODE
+# Support silent build rules, requires at least automake-1.11. Disable
+# by either passing --disable-silent-rules to configure or passing V=1
+# to make
+m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES([yes])])
# Checks for programs.
-AC_DISABLE_STATIC
-AC_PROG_LIBTOOL
AC_PROG_CC
AM_PROG_CC_C_O
+# Initialize libtool
+LT_PREREQ([2.2])
+LT_INIT([disable-static])
+
PKG_CHECK_MODULES(DRM, [libdrm_intel >= 2.4.23], have_drm=yes, have_drm=no)
if test "x$have_drm" = "xyes"; then
AC_DEFINE([HAVE_DRM], 1, [Define to 1 if we have DRM support])
@@ -82,7 +89,7 @@ m4_ifndef([XORG_MACROS_VERSION], [AC_FATAL([must install xorg-macros 1.3 or late
XORG_MACROS_VERSION(1.3)
XORG_DEFAULT_OPTIONS
-AC_OUTPUT([
+AC_CONFIG_FILES([
Makefile
benchmarks/Makefile
lib/Makefile
@@ -90,3 +97,4 @@ AC_OUTPUT([
tests/Makefile
tools/Makefile
])
+AC_OUTPUT