summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBen Widawsky <ben@bwidawsk.net>2011-06-24 11:42:03 -0700
committerBen Widawsky <ben@bwidawsk.net>2011-07-28 14:26:57 -0700
commit62873796c4a96554cc139e9aa49e25ce19cd65cd (patch)
tree94ec773aca3881e696bd6f1067ec16beb4056e9a /configure.ac
parente39b13d7e4174ec50fd41d74fe8d3375c8ef2850 (diff)
intel-gpu-tools/debugging: shader debugger
high level summary of the files: * debug_rdata - get current state from debug registers. Helpful when developing the debugger, and could serve some purpose in the future. * eudb - the debugger itself * eviction_macro - generate the proper macro to flush the EU render cache until I get control flow working * pre_cpp - an evaluating c preprocesser like thing, to be used before cpp * sr - the system routine, exception handler which runs on the EU * test - a very basic test system routine * debug.h
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4eb1c48..4629dec 100644
--- a/configure.ac
+++ b/configure.ac
@@ -86,6 +86,16 @@ fi
AC_SUBST([WARN_CFLAGS])
+AC_ARG_ENABLE(shader-debugger,
+ AS_HELP_STRING([--enable-shader-debugger],
+ [Enable shader debugging support [default=no]]),
+ [SHADER_DEBUGGER="$enableval"],
+ [SHADER_DEBUGGER=no])
+AM_CONDITIONAL(HAVE_SHADER_DEBUGGER, [test "x$SHADER_DEBUGGER" = xyes])
+if test "x$SHADER_DEBUGGER" = xyes; then
+ AC_DEFINE(HAVE_SHADER_DEBUGGER, 1, [Have shader debugging support])
+fi
+
m4_ifndef([XORG_MACROS_VERSION], [AC_FATAL([must install xorg-macros 1.3 or later before running autoconf/autogen])])
XORG_MACROS_VERSION(1.3)
XORG_DEFAULT_OPTIONS
@@ -98,5 +108,6 @@ AC_CONFIG_FILES([
scripts/Makefile
tests/Makefile
tools/Makefile
+ debugger/Makefile
])
AC_OUTPUT