summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEugeni Dodonov <eugeni.dodonov@intel.com>2011-11-09 11:37:38 -0200
committerEugeni Dodonov <eugeni.dodonov@intel.com>2011-11-09 11:50:22 -0200
commitf3c4c0499291cf484ecbef7154d42db4129a44f1 (patch)
treebcaa175ea4eb6ff36ae0e70015f7e1a8d748b132 /configure.ac
parentdf914160599e71af95f428c3cf59165fba92d102 (diff)
intel_gpu_top: use system-specific defines instead of autoconf flag
As suggested by Konstantin Belousov, using __linux__ would be easier, remove the --enable-linux-features compile flag, and also make porting easier. So we do it, and check for __linux__ during compilation, and only compile linux-specific bits when we are on Linux. Other systems can extend the proposed functions with system-specific value aquisition (for now, CPU and GPU/ACPI power monitoring). Signed-off-by: Eugeni Dodonov <eugeni.dodonov@intel.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 0 insertions, 10 deletions
diff --git a/configure.ac b/configure.ac
index 65947f9..3e1218e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -97,16 +97,6 @@ if test "x$SHADER_DEBUGGER" = xyes; then
fi
fi
-AC_ARG_ENABLE(linux-features,
- AS_HELP_STRING([--enable-linux-features],
- [Enable additional Linux-specific features [default=no]]),
- [LINUX_FEATURES="$enableval"],
- [LINUX_FEATURES=no])
-AM_CONDITIONAL(HAVE_LINUX_FEATURES, [test "x$LINUX_FEATURES" = xyes])
-if test "x$LINUX_FEATURES" = xyes; then
- AC_DEFINE(HAVE_LINUX_FEATURES, 1, [Have linux-specific features])
-fi
-
m4_ifndef([XORG_MACROS_VERSION], [AC_FATAL([must install xorg-macros 1.3 or later before running autoconf/autogen])])
XORG_MACROS_VERSION(1.3)
XORG_DEFAULT_OPTIONS