summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 5 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index d1b105ef..c4b38d89 100644
--- a/configure.ac
+++ b/configure.ac
@@ -644,9 +644,11 @@ case $host in
;;
esac
-AM_CONDITIONAL(BUILD_TRACE,
- test "x$have_ld_preload" = "xyes" \
- -a "x$have_libz" = "xyes")
+CAIRO_ENABLE(trace, cairo-trace, yes, [
+ if test "x$have_ld_preload" != "xyes" -o "x$have_libz" != "xyes"; then
+ use_trace="no (requires dynamic linker and zlib)"
+ fi
+])
AM_CONDITIONAL(BUILD_SCRIPT, test "x$have_libz" = "xyes")