summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorGwenole Beauchesne <gbeauchesne@splitted-desktop.com>2009-07-08 07:54:44 +0000
committerAustin Yuan <shengquan.yuan@intel.com>2009-08-28 11:00:00 +0800
commite2a24f0189561cc4feaf00d0b48f22947704ae56 (patch)
tree0e398b0c611b7dfc19bd0fe7bd3a47099e3f6dfd /Makefile.am
parent4e71a2ddfd56543c60e91525726d136a526d1162 (diff)
Split libva DSO into core (libva.so) and display-dependent parts (libva-x11.so).
Signed-off-by: Austin Yuan <shengquan.yuan@intel.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 7 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index cd0ee58..f2defab 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -31,11 +31,16 @@ SUBDIRS += i965_drv_video
endif
pcfiles = \
- libva.pc
+ libva.pc \
+ libva-$(LIBVA_DISPLAY).pc
+
+# libva-<display>.pc - for display-specific dependencies
+libva-$(LIBVA_DISPLAY).pc: libva_display.pc
+ @cp $< $@
pkgconfigdir = @pkgconfigdir@
pkgconfig_DATA = $(pcfiles)
-EXTRA_DIST = libva.pc.in
+EXTRA_DIST = libva.pc.in libva_display.pc.in
CLEANFILES = $(pcfiles)