summaryrefslogtreecommitdiff
path: root/doc/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'doc/meson.build')
-rw-r--r--doc/meson.build22
1 files changed, 22 insertions, 0 deletions
diff --git a/doc/meson.build b/doc/meson.build
new file mode 100644
index 0000000..c00894e
--- /dev/null
+++ b/doc/meson.build
@@ -0,0 +1,22 @@
+doc_option = get_option('documentation')
+doc_required = doc_option == 'true'
+docdir = join_paths(get_option('datadir'), 'doc', 'libvdpau')
+
+doxygen = find_program('doxygen', required : doc_required)
+dot = find_program('dot', required : doc_required)
+
+if doc_option != 'false' and doxygen.found() and dot.found()
+ doxyfile = configure_file(
+ input : 'Doxyfile.in',
+ output : 'Doxyfile',
+ configuration : cdata,
+ install : false
+ )
+
+ html = custom_target('libvdpau-docs',
+ command : [doxygen, doxyfile],
+ output : 'html',
+ install : true,
+ install_dir : docdir,
+ )
+endif