summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAaron Plattner <aplattner@nvidia.com>2006-06-19 09:32:11 -0700
committerAaron Plattner <aplattner@nvidia.com>2006-06-19 09:32:11 -0700
commit5114639dff73c22845451acffed94f1da284a7df (patch)
treed0a9278df4971faad5437bf8559a2fd58b1b8ad2 /Makefile.am
parent04d344dfcbb9928cf33943a880de333557e14be9 (diff)
Generate the ChangeLog from git history for dist.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index ce96d2f..3a02f4e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -21,4 +21,10 @@
AUTOMAKE_OPTIONS = foreign
SUBDIRS = src man
-EXTRA_DIST = README.NV1
+EXTRA_DIST = README.NV1 ChangeLog
+
+# Always regenerate the changelog
+CLEANFILES = ChangeLog
+ChangeLog: FORCE
+ git-log > ChangeLog
+FORCE: