summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChris Wilson <chris@chris-wilson.co.uk>2011-12-11 16:23:13 +0000
committerChris Wilson <chris@chris-wilson.co.uk>2011-12-11 16:23:13 +0000
commit2674ef864c93034d728ee11ee0b7ab96cd4cba57 (patch)
tree09625734ec09244ac3a201872f6af20b2d36b7b0 /configure.ac
parentc83fd4e24de187700bc125037cd9ae311514213e (diff)
sna: Enable hooking up of valgrind during debugging
Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a675a933..6dbeb285 100644
--- a/configure.ac
+++ b/configure.ac
@@ -263,6 +263,8 @@ if test "x$DEBUG" != xno; then
fi
if test "x$DEBUG" = xfull; then
AC_DEFINE(HAS_DEBUG_FULL,1,[Enable all debugging])
+ PKG_CHECK_MODULES(VALGRIND, [valgrind],
+ AC_DEFINE([HAVE_VALGRIND], 0, [Use valgind intrinsics to suppress false warings]),)
CFLAGS="$CFLAGS -O0 -ggdb3"
fi