summaryrefslogtreecommitdiff
path: root/hw/xfree86/common/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'hw/xfree86/common/Makefile.am')
-rw-r--r--hw/xfree86/common/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/hw/xfree86/common/Makefile.am b/hw/xfree86/common/Makefile.am
index f8fcde956..532d87bbe 100644
--- a/hw/xfree86/common/Makefile.am
+++ b/hw/xfree86/common/Makefile.am
@@ -15,6 +15,7 @@ XVSDKINCS = xf86xv.h xf86xvmc.h xf86xvpriv.h
endif
if XF86VIDMODE
+XF86VMODESOURCES = xf86vmode.c
XF86VMODE_SDK = vidmodeproc.h
endif
@@ -47,7 +48,7 @@ libcommon_la_SOURCES = xf86Configure.c xf86Bus.c xf86Config.c \
xf86VidMode.c xf86fbman.c xf86cmap.c \
xf86Helper.c xf86PM.c xf86Xinput.c xisb.c \
xf86Mode.c xorgHelper.c xf86Extensions.h \
- xf86Extensions.c xf86vmode.c \
+ xf86Extensions.c $(XF86VMODESOURCES) \
$(XVSOURCES) $(BUSSOURCES) $(RANDRSOURCES)
nodist_libcommon_la_SOURCES = xf86DefModeSet.c xf86Build.h
libcommon_la_LIBADD = $(top_builddir)/config/libconfig.la