summaryrefslogtreecommitdiff
path: root/hw/kdrive/chips/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'hw/kdrive/chips/Makefile.am')
-rw-r--r--hw/kdrive/chips/Makefile.am28
1 files changed, 28 insertions, 0 deletions
diff --git a/hw/kdrive/chips/Makefile.am b/hw/kdrive/chips/Makefile.am
new file mode 100644
index 000000000..6e7481e90
--- /dev/null
+++ b/hw/kdrive/chips/Makefile.am
@@ -0,0 +1,28 @@
+INCLUDES = \
+ @KDRIVE_INCS@ \
+ -I$(top_srcdir)/hw/kdrive/vesa \
+ @XSERVER_CFLAGS@
+
+bin_PROGRAMS = Xchips
+
+if TSLIB
+TSLIB_FLAG = -lts
+endif
+
+noinst_LIBRARIES = libchips.a
+
+libchips_a_SOURCES = \
+ chipsdraw.c \
+ chips.c \
+ chips.h
+
+Xchips_SOURCES = \
+ chipsstub.c
+
+Xchips_LDADD = \
+ libchips.a \
+ $(top_builddir)/hw/kdrive/vesa/libvesa.a \
+ @KDRIVE_LIBS@ \
+ @XSERVER_LIBS@ \
+ $(TSLIB_FLAG)
+