summaryrefslogtreecommitdiff
path: root/GL/mesa/shader/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'GL/mesa/shader/Makefile.am')
-rw-r--r--GL/mesa/shader/Makefile.am15
1 files changed, 14 insertions, 1 deletions
diff --git a/GL/mesa/shader/Makefile.am b/GL/mesa/shader/Makefile.am
index fb977f02d..a8b00144d 100644
--- a/GL/mesa/shader/Makefile.am
+++ b/GL/mesa/shader/Makefile.am
@@ -1,5 +1,17 @@
noinst_LTLIBRARIES = libshader.la
+INCLUDES = -I@mesadir@/include \
+ -I$(srcdir)/../X \
+ -I$(srcdir)/../array_cache \
+ -I$(srcdir)/../glapi \
+ -I$(srcdir)/../main \
+ -I$(srcdir)/../math \
+ -I$(srcdir)/../shader \
+ -I$(srcdir)/../swrast \
+ -I$(srcdir)/../swrast_setup \
+ -I$(srcdir)/../tnl \
+ -I$(srcdir)/..
+
libshader_la_SOURCES = arbfragparse.c \
arbprogparse.c \
arbprogram.c \
@@ -11,4 +23,5 @@ libshader_la_SOURCES = arbfragparse.c \
nvvertparse.c \
program.c \
shaderobjects.c \
- shaderobjects_3dlabs.c
+ shaderobjects_3dlabs.c \
+ grammar_mesa.c