summaryrefslogtreecommitdiff
path: root/meson_options.txt
diff options
context:
space:
mode:
authorAaron Plattner <aplattner@nvidia.com>2018-05-02 12:54:26 -0700
committerAdam Jackson <ajax@redhat.com>2018-05-09 13:36:25 -0400
commitb6bf68b8416ec4b717eb78703fb63789c68e509a (patch)
treed084ac06afb78070da4ecc174de66db480148937 /meson_options.txt
parent9d628ee5facf6318368d5b8ca181e083adcffe8c (diff)
meson: Fix module_dir configuration (v2)
meson.build has code to set the module_dir variable to ${libdir}/xorg/modules if the module_dir option string is empty. However, this has several problems: 1. The variable is only used for an unused @moduledir@ substitution in the man page. The rule for xorg-server.pc uses option('module_dir') directly instead. 2. The 'module_dir' option has a default value of 'xorg/modules' so the above rule doesn't do anything by default. 3. The xorg-server.pc rule uses ${exec_prefix}/option('module_dir'), so the effect of #2 is that the default moduledir is different between autoconf and meson. E.g. if ${prefix} is /X, then you get autoconf: moduledir=/X/lib/xorg/modules meson: moduledir=/X/xorg/modules Fix this by using the module_dir variable when generating xorg-server.pc, and by using join_paths() to assign module_dir unconditionally. v2: Keep the 'xorg/modules' default path, but use join_paths() unconditionally (Thierry Reding) Signed-off-by: Aaron Plattner <aplattner@nvidia.com> Reviewed-by: Peter Hutterer <peter.hutterer@who-t.net>
Diffstat (limited to 'meson_options.txt')
-rw-r--r--meson_options.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson_options.txt b/meson_options.txt
index a296838a1..86fca4668 100644
--- a/meson_options.txt
+++ b/meson_options.txt
@@ -22,7 +22,7 @@ option('builder_string', type: 'string', description: 'Additional builder string
option('log_dir', type: 'string')
option('module_dir', type: 'string', value: 'xorg/modules',
- description: 'X.Org modules directory')
+ description: 'X.Org modules directory (absolute or relative to the directory specified by the libdir option)')
option('default_font_path', type: 'string')
option('glx', type: 'boolean', value: true)