summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorAdam Jackson <ajax@redhat.com>2019-08-27 18:10:38 -0400
committerAdam Jackson <ajax@redhat.com>2020-02-12 16:56:13 -0500
commitee9f6e20de1408d572dc1eba33f3d2a8501d7da5 (patch)
tree295e7320d9c45a13776d38f2983057316f055897 /meson.build
parent42aaf37241fedfd6a0f72b255f2d45d6ea34d8c6 (diff)
meson: Add support for libunwind
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 4 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 82942bd94..32ce9f042 100644
--- a/meson.build
+++ b/meson.build
@@ -639,6 +639,10 @@ if host_machine.system() == 'windows'
common_dep += socket_dep
endif
+if get_option('libunwind')
+ common_dep += dependency('libunwind', required: true)
+endif
+
glx_inc = include_directories('glx')
top_dir_inc = include_directories('.')