summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorJon Turney <jon.turney@dronecode.org.uk>2019-04-20 12:45:11 +0100
committerAdam Jackson <ajax@nwnk.net>2019-05-02 15:42:58 +0000
commitb4ed20c4f118031305f6ce76dda4e325950b2958 (patch)
tree93741f6a61db2452296e1f6cbcbf8b79c587ada4 /meson.build
parent71cff63c06a6b494dc8921270535f33fb78bd32b (diff)
Promote file containing date & time build was configured to top-level
Promote the generated file containing the date & time build was configured to top-level. Rename it from xf86Build.h to buildDateTIme.h. Use it as well in XQuartz, stringize BUILD_DATE when needed.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build8
1 files changed, 7 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index e835e2d31..75261f4b7 100644
--- a/meson.build
+++ b/meson.build
@@ -531,7 +531,7 @@ endif
glx_inc = include_directories('glx')
-top_srcdir_inc = include_directories('.')
+top_dir_inc = include_directories('.')
serverconfigdir = join_paths(get_option('libdir'), 'xorg')
@@ -566,6 +566,12 @@ manpage_config.set('modulepath', module_dir)
manpage_config.set('suid_wrapper_dir', join_paths(get_option('prefix'), 'libexec'))
manpage_config.set('default_font_path', default_font_path)
+# generate header containing date & time build was configued
+build_date_time = configure_file(
+ output: 'buildDateTime.h',
+ command: ['sh', join_paths(meson.current_source_dir(), 'buildDateTime.sh'), '@OUTPUT@'],
+)
+
# Include must come first, as it sets up dix-config.h
subdir('include')