summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorAdam Jackson <ajax@redhat.com>2019-08-27 15:54:42 -0400
committerAdam Jackson <ajax@redhat.com>2019-08-27 17:38:59 -0400
commit7d0e660e0e2808e098ab9d4de843e9b31c64af21 (patch)
tree58929e75456b962b36f89f1db69b5f5b75ea4126 /meson.build
parente0e051a3920e3e2731d35807e00d30ba9ef7f122 (diff)
meson: Add dtrace support
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 5 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index def32e9b9..00a7e3c86 100644
--- a/meson.build
+++ b/meson.build
@@ -175,6 +175,11 @@ else
build_systemd_logind = get_option('systemd_logind') == 'true'
endif
+with_dtrace = get_option('dtrace')
+if with_dtrace
+ dtrace = find_program('dtrace', required: true)
+endif
+
build_xorg = false
if (host_machine.system() != 'darwin' and
host_machine.system() != 'windows')