summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorJon Turney <jon.turney@dronecode.org.uk>2019-04-18 17:06:41 +0100
committerAdam Jackson <ajax@nwnk.net>2019-05-02 15:42:58 +0000
commit655b1eb32e3f7f9ba587e878a691fbc9195e81f5 (patch)
tree389bf0570c2225b5b312170abebb05573f068e72 /meson.build
parente5f4c7c80b3f15b1941c530e58fbded0fd06a97e (diff)
meson: Convert xquartz from autotools
Differences from autotools: * Autotools defined NO_ALLOCA for OSX builds. I don't think we need this anymore as Xalloc.h is no longer used anywhere in the xserver. * X11.bin is linked with -u,miDCInitialize, and then libserver_mi provided to satisfy (just) that. It's been that way since the commit which added it. We can't write the equivalent in meson due to linker argument ordering issues, but do we really need to? * An explicit -Dsecure-rpc=false is required for OSX, since in meson we don't do the checks that XTRANS_SECURE_RPC_FLAGS did for the existence of the specific RPC functions required.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build25
1 files changed, 19 insertions, 6 deletions
diff --git a/meson.build b/meson.build
index 85c045ee3..08395ff62 100644
--- a/meson.build
+++ b/meson.build
@@ -6,7 +6,7 @@ project('xserver', 'c',
version: '1.20.99.1',
meson_version: '>= 0.46.0',
)
-add_project_arguments('-DHAVE_DIX_CONFIG_H', language: 'c')
+add_project_arguments('-DHAVE_DIX_CONFIG_H', language: ['c', 'objc'])
cc = meson.get_compiler('c')
add_global_arguments('-fno-strict-aliasing', language : 'c')
@@ -56,7 +56,7 @@ foreach wflag: test_wflags
endif
endforeach
-add_global_arguments(common_wflags, language : 'c')
+add_global_arguments(common_wflags, language : ['c', 'objc'])
xproto_dep = dependency('xproto', version: '>= 7.0.31')
randrproto_dep = dependency('randrproto', version: '>= 1.6.0')
@@ -133,14 +133,21 @@ dfp = get_option('default_font_path')
if dfp == ''
fontutil_dep = dependency('fontutil')
fontrootdir = fontutil_dep.get_pkgconfig_variable('fontrootdir')
- default_font_path = ','.join([
+ dfp_elements = [
join_paths(fontrootdir, 'misc'),
join_paths(fontrootdir, 'TTF'),
join_paths(fontrootdir, 'OTF'),
join_paths(fontrootdir, 'Type1'),
join_paths(fontrootdir, '100dpi'),
join_paths(fontrootdir, '75dpi'),
- ])
+ ]
+ if host_machine.system() == 'darwin'
+ dfp_elements += [
+ '/Library/Fonts',
+ '/System/Library/Fonts',
+ ]
+ endif
+ default_font_path = ','.join(dfp_elements)
else
default_font_path = dfp
endif
@@ -149,7 +156,7 @@ hal_option = get_option('hal')
glamor_option = get_option('glamor')
build_udev = get_option('udev')
-if host_machine.system() == 'windows'
+if host_machine.system() == 'windows' or host_machine.system() == 'darwin'
build_udev = false
hal_option = 'false'
endif
@@ -227,8 +234,14 @@ else
build_xwin = get_option('xwin') == 'true'
endif
-# XXX: Finish these.
build_xquartz = false
+if get_option('xquartz') == 'auto'
+ if host_machine.system() == 'darwin'
+ build_xquartz = true
+ endif
+else
+ build_xquartz = get_option('xquartz') == 'true'
+endif
build_rootless = false
if build_xquartz