summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorMichel Dänzer <mdaenzer@redhat.com>2020-10-23 12:40:41 +0200
committerMichel Dänzer <michel@daenzer.net>2021-02-03 18:21:08 +0100
commit274d54d1c3876fd8c5142f43cd9204c0de417e92 (patch)
treed0feb2d23ed83680ccae979db17af16dccaad678 /meson.build
parentbe7257c5d1401e098f2d43a917371b8c8d37edea (diff)
meson: Build Xwayland unconditionally
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build46
1 files changed, 13 insertions, 33 deletions
diff --git a/meson.build b/meson.build
index 1e2689bb3..21ba99234 100644
--- a/meson.build
+++ b/meson.build
@@ -153,36 +153,22 @@ if with_dtrace
dtrace = find_program('dtrace', required: true)
endif
-build_xwayland = false
-if (host_machine.system() != 'darwin' and
- host_machine.system() != 'windows')
- if get_option('xwayland') != 'false'
- xwayland_required = get_option('xwayland') == 'true'
- build_glamor = glamor_option == 'true' or glamor_option == 'auto'
-
- xwayland_path = get_option('xwayland-path')
- if (xwayland_path == '')
- xwayland_path = join_paths(get_option('prefix'), get_option('bindir'))
- endif
+build_xwayland = true
+build_glamor = glamor_option != 'false'
- xwayland_dep = [
- dependency('wayland-client', version: wayland_req, required: xwayland_required),
- dependency('wayland-protocols', version: wayland_protocols_req, required: xwayland_required),
- ]
+xwayland_path = get_option('xwayland-path')
+if (xwayland_path == '')
+ xwayland_path = join_paths(get_option('prefix'), get_option('bindir'))
+endif
- if build_glamor
- xwayland_dep += dependency('libdrm', version: libdrm_req, required: xwayland_required)
- xwayland_dep += dependency('epoxy', required: xwayland_required)
- endif
+xwayland_dep = [
+ dependency('wayland-client', version: wayland_req, required: true),
+ dependency('wayland-protocols', version: wayland_protocols_req, required: true),
+]
- build_xwayland = true
- # check for all the deps being found, to handle 'auto' mode.
- foreach d: xwayland_dep
- if not d.found()
- build_xwayland = false
- endif
- endforeach
- endif
+if build_glamor
+ xwayland_dep += dependency('libdrm', version: libdrm_req, required: true)
+ xwayland_dep += dependency('epoxy', required: true)
endif
if get_option('ipv6') == 'auto'
@@ -191,12 +177,6 @@ else
build_ipv6 = get_option('ipv6') == 'true'
endif
-if glamor_option == 'auto'
- build_glamor = build_xwayland
-else
- build_glamor = glamor_option == 'true'
-endif
-
gbm_dep = dependency('', required: false)
epoxy_dep = dependency('', required: false)
if build_glamor