summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorMichel Dänzer <mdaenzer@redhat.com>2020-10-23 19:03:49 +0200
committerMichel Dänzer <michel@daenzer.net>2021-02-03 18:15:10 +0100
commit23296633bb221242aac631a542762cca240abf4f (patch)
tree48898b986fc3cd8c0ee94176dc5d1b0c08486237 /meson.build
parent9335ee79942c25e5b71debfde8b4f288287d4314 (diff)
Drop config directory
Not used anymore on this branch.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build52
1 files changed, 0 insertions, 52 deletions
diff --git a/meson.build b/meson.build
index 1ba9ae770..05f782408 100644
--- a/meson.build
+++ b/meson.build
@@ -95,15 +95,6 @@ xkbcomp_dep = dependency('xkbcomp', required: false)
xkbfile_dep = dependency('xkbfile')
xfont2_dep = dependency('xfont2', version: '>= 2.0')
-dbus_required = get_option('systemd_logind') == 'true'
-dbus_dep = dependency('dbus-1', version: '>= 1.0', required: dbus_required)
-
-# libsystemd-daemon was moved into libsystemd in version 209
-libsystemd_daemon_dep = dependency('libsystemd', version: '>= 209', required: false)
-if not libsystemd_daemon_dep.found()
- libsystemd_daemon_dep = dependency('libsystemd-daemon', required: false)
-endif
-
build_hashtable = false
# Resolve default values of some options
@@ -155,23 +146,8 @@ else
default_font_path = dfp
endif
-hal_option = get_option('hal')
glamor_option = get_option('glamor')
-build_udev = get_option('udev')
-build_udev_kms = get_option('udev_kms')
-if ['windows', 'darwin', 'cygwin'].contains(host_machine.system())
- build_udev = false
- build_udev_kms = false
- hal_option = 'false'
-endif
-
-if get_option('systemd_logind') == 'auto'
- build_systemd_logind = build_udev_kms and dbus_dep.found()
-else
- build_systemd_logind = get_option('systemd_logind') == 'true'
-endif
-
with_dtrace = get_option('dtrace')
if with_dtrace
dtrace = find_program('dtrace', required: true)
@@ -215,32 +191,6 @@ else
build_ipv6 = get_option('ipv6') == 'true'
endif
-hal_dep = []
-if hal_option == 'auto'
- if not build_udev
- hal_dep = dependency('hal', required: false)
- build_hal = hal_dep.found()
- else
- build_hal = false
- endif
-else
- build_hal = hal_option == 'true'
- if build_hal
- hal_dep = dependency('hal')
- endif
-endif
-
-if build_udev and build_hal
- error('Hotplugging through both libudev and hal not allowed')
-endif
-
-build_dbus = build_hal or build_systemd_logind
-
-udev_dep = dependency('', required:false)
-if build_udev or build_udev_kms
- udev_dep = dependency('libudev', version: '>= 143')
-endif
-
if glamor_option == 'auto'
build_glamor = build_xwayland
else
@@ -437,7 +387,6 @@ common_dep = [
xcmiscproto_dep,
bigreqsproto_dep,
xtrans_dep,
- libsystemd_daemon_dep,
videoproto_dep,
compositeproto_dep,
@@ -540,7 +489,6 @@ manpage_config.set('default_font_path', default_font_path)
subdir('include')
# X server core
-subdir('config')
subdir('dix')
subdir('dri3')
subdir('glx')