summaryrefslogtreecommitdiff
path: root/hw/xfree86/os-support/Makefile.am
diff options
context:
space:
mode:
authorDave Airlie <airlied@linux.ie>2006-11-09 09:30:33 +1100
committerDave Airlie <airlied@linux.ie>2006-11-09 09:30:33 +1100
commitfd91630b73100e9d77ccb492c52807448bc772a5 (patch)
tree44892b9943ff32d18960488fe39265fbba9b8f0c /hw/xfree86/os-support/Makefile.am
parent0409e1627a167db2efc1355f292d3c02a6989ffc (diff)
make X server use system libdrm - this requires libdrm >= 2.3.0
This patch blacklists the load "drm" line, moves some functions in dri module links dri module against libdrm, and removes the X copy of libdrm
Diffstat (limited to 'hw/xfree86/os-support/Makefile.am')
-rw-r--r--hw/xfree86/os-support/Makefile.am6
1 files changed, 1 insertions, 5 deletions
diff --git a/hw/xfree86/os-support/Makefile.am b/hw/xfree86/os-support/Makefile.am
index b07e3c9ae..f9a888e2f 100644
--- a/hw/xfree86/os-support/Makefile.am
+++ b/hw/xfree86/os-support/Makefile.am
@@ -1,14 +1,10 @@
-if DRI
-DRI_SUBDIRS=drm
-endif
-
SUBDIRS = bus @XORG_OS_SUBDIR@ misc $(DRI_SUBDIRS)
DIST_SUBDIRS = bsd bus drm misc linux lynxos solaris sysv sco usl hurd
sdk_HEADERS = xf86_OSproc.h xf86_OSlib.h xf86_ansic.h xf86_libc.h \
assyntax.h xf86OSmouse.h
-EXTRA_DIST = int10Defines.h xf86OSpriv.h README.OS-lib xf86drm.h
+EXTRA_DIST = int10Defines.h xf86OSpriv.h README.OS-lib
# to get the grouping semantics right, you have to glom these three together
# as one library, otherwise libtool will actively defeat your attempts to