summaryrefslogtreecommitdiff
path: root/hw/xfree86/dixmods/extmod/Makefile.am
diff options
context:
space:
mode:
authorKevin E Martin <kem@kem.org>2005-07-16 03:46:01 +0000
committerKevin E Martin <kem@kem.org>2005-07-16 03:46:01 +0000
commit0635acab08bade9bfd9d2abd3ea5a3fe525bc647 (patch)
tree84a9d5bd0408b587cc3ff58b3202a13c092a3199 /hw/xfree86/dixmods/extmod/Makefile.am
parent92b23ff426936909e1ff5e063b75e5f112b93ca1 (diff)
Add record module building support Change module building to not use
-include Fix xnest, dmx and vfb builds to -DXFree86Server for fbcmap compilation
Diffstat (limited to 'hw/xfree86/dixmods/extmod/Makefile.am')
-rw-r--r--hw/xfree86/dixmods/extmod/Makefile.am25
1 files changed, 14 insertions, 11 deletions
diff --git a/hw/xfree86/dixmods/extmod/Makefile.am b/hw/xfree86/dixmods/extmod/Makefile.am
index 95fa0505b..aec4cabf2 100644
--- a/hw/xfree86/dixmods/extmod/Makefile.am
+++ b/hw/xfree86/dixmods/extmod/Makefile.am
@@ -7,17 +7,20 @@ if XV
XV_SRCS = xvmod.c
endif
-# yes, this is a cheesy hack.
-AM_CFLAGS = $(XORG_CFLAGS) -include xorg-config.h
-INCLUDES = $(XORG_INCS) -I$(top_srcdir)/afb -I$(top_srcdir)/mfb \
- -I$(top_srcdir)/cfb -I$(top_srcdir)/dbe -I$(srcdir)/../loader \
- -I$(top_srcdir)/miext/layer -I$(top_srcdir)/miext/shadow
+AM_CFLAGS = @XORG_CFLAGS@
+INCLUDES = @XORG_INCS@ \
+ -I$(top_srcdir)/afb \
+ -I$(top_srcdir)/mfb \
+ -I$(top_srcdir)/cfb \
+ -I$(top_srcdir)/dbe \
+ -I$(top_srcdir)/hw/xfree86/loader \
+ -I$(top_srcdir)/miext/layer \
+ -I$(top_srcdir)/miext/shadow
libextmod_la_LDFLAGS = -avoid-version
libextmod_la_LIBADD = $(top_srcdir)/Xext/libXext.la
-libextmod_la_SOURCES = \
- modinit.c \
- $(DGA_SRCS) \
- xf86misc.c \
- xf86vmode.c \
- $(XV_SRCS)
+libextmod_la_SOURCES = modinit.c \
+ $(DGA_SRCS) \
+ xf86misc.c \
+ xf86vmode.c \
+ $(XV_SRCS)