summaryrefslogtreecommitdiff
path: root/hw/xfree86/Makefile.am
diff options
context:
space:
mode:
authorDaniel Stone <daniel@fooishbar.org>2005-08-20 18:07:59 +0000
committerDaniel Stone <daniel@fooishbar.org>2005-08-20 18:07:59 +0000
commitbb1d99ee72cc560e95010ea1008d5e796177ae62 (patch)
tree2a6406eb3c5dbaa1fecee664c2ca42396195eb80 /hw/xfree86/Makefile.am
parent8a32ed46480d78b69f289c90098f5ed4a830851f (diff)
Build libxkbstubs.la to stub XKB DDX functions (e.g. VT switches), and
build libxorggxkb.la from within the Xorg DDX to replace the previous xf86VT.o, et al, hacks.
Diffstat (limited to 'hw/xfree86/Makefile.am')
-rw-r--r--hw/xfree86/Makefile.am30
1 files changed, 1 insertions, 29 deletions
diff --git a/hw/xfree86/Makefile.am b/hw/xfree86/Makefile.am
index 6924a6423..3dd5adceb 100644
--- a/hw/xfree86/Makefile.am
+++ b/hw/xfree86/Makefile.am
@@ -47,37 +47,9 @@ XORG_LIBS = \
dixmods/libdixmods.la \
@XORG_LIBS@
-#
-# The xkbVT.c xkbKillSrv.c and xkbPrivate.c files used below are really
-# the same files as ddxVT.c ddxKillSrv.c and ddxPrivate.c from
-# $(top_srcdir)/xkb. However they are compiled with the flag
-# XF86DDXACTIONS which means they'll do stuff like Ctrl-Alt-Fx etc.
-# They have to be last on the link line so that their symbols will
-# override the ones from libxkb.a.
-#
-# Unfortunately, those symbols can't be removed from libxkb because that
-# causes other ddx'es to break. One possible fix would be to turn libxkb
-# into shared a shared library and add API that would people linking to
-# it to install callbacks for those actions.
-#
-
-xkbVT.c:
- echo "#define XF86DDXACTIONS" > $@
- echo "#include \"$(top_srcdir)/xkb/ddxVT.c\"" >> $@
-
-xkbKillSrv.c:
- echo "#define XF86DDXACTIONS" > $@
- echo "#include \"$(top_srcdir)/xkb/ddxKillSrv.c\"" >> $@
-
-xkbPrivate.c:
- echo "#define XF86DDXACTIONS" > $@
- echo "#include \"$(top_srcdir)/xkb/ddxPrivate.c\"" >> $@
-
Xorg_LDADD = $(XORG_LIBS) \
@XSERVER_LIBS@ \
- xkbVT.o \
- xkbKillSrv.o \
- xkbPrivate.o \
+ dixmods/libxorgxkb.la \
-ldl
Xorg_LDFLAGS = $(LD_EXPORT_SYMBOLS_FLAG)