summaryrefslogtreecommitdiff
path: root/hw/xfree86/Makefile.am
diff options
context:
space:
mode:
authorAlan Coopersmith <Alan.Coopersmith@sun.com>2005-09-24 02:40:51 +0000
committerAlan Coopersmith <Alan.Coopersmith@sun.com>2005-09-24 02:40:51 +0000
commita5477ae7ac9a56c1a586950db1dee6661bff149d (patch)
tree9a8b4f0b8b31ced285741ef75e872c6c3f697af8 /hw/xfree86/Makefile.am
parent2ba865b3f57340fd1d75f7614c17f615cc127b89 (diff)
Add scanpci, xorgcfg, & xorgconfig utilities.
Diffstat (limited to 'hw/xfree86/Makefile.am')
-rw-r--r--hw/xfree86/Makefile.am19
1 files changed, 4 insertions, 15 deletions
diff --git a/hw/xfree86/Makefile.am b/hw/xfree86/Makefile.am
index 413a1f615..490d2d41e 100644
--- a/hw/xfree86/Makefile.am
+++ b/hw/xfree86/Makefile.am
@@ -4,11 +4,12 @@ endif
SUBDIRS = common ddc dummylib i2c x86emu int10 fbdevhw os-support parser rac \
ramdac shadowfb vbe vgahw xaa xf1bpp xf4bpp xf8_16bpp \
- xf8_32bpp xf8_32wid loader scanpci dixmods exa $(DRI_SUBDIR)
+ xf8_32bpp xf8_32wid loader scanpci dixmods exa $(DRI_SUBDIR) utils
DIST_SUBDIRS = common ddc dummylib i2c x86emu int10 fbdevhw os-support \
parser rac ramdac shadowfb vbe vgahw xaa xf1bpp xf4bpp \
- xf8_16bpp xf8_32bpp xf8_32wid loader scanpci dixmods dri exa
+ xf8_16bpp xf8_32bpp xf8_32wid loader scanpci dixmods dri exa \
+ utils
bin_PROGRAMS = Xorg
@@ -22,19 +23,7 @@ DISTCLEANFILES = xorg.c
xorg.c:
touch $@
-xorgos.c:
- touch $@
-
-# to get the grouping semantics right, you have to glom these three together
-# as one library, otherwise libtool will actively defeat your attempts to
-# list them multiple times on the link line.
-noinst_LTLIBRARIES = libxorgos.la
-libxorgos_la_SOURCES = xorgos.c
-libxorgos_la_LIBADD = os-support/@XORG_OS_SUBDIR@/lib@XORG_OS_SUBDIR@.la \
- os-support/bus/libbus.la \
- os-support/misc/libmisc.la
-
-OS_LIBS = libxorgos.la
+OS_LIBS = os-support/libxorgos.la
XORG_LIBS = \
@XORG_CORE_LIBS@ \